Data imports into eazyBI accounts with the Xray app are failing

Incident Report for eazyBI

Postmortem

The incident was caused by an incomplete solution for Xray data import changes. Import via the Xray GraphQL API was added alongside backup processing, but unlike backups, the GraphQL API enforces project-level permissions — so instance admins who could access the full Xray backup were denied data for projects where they lacked explicit access.

Posted Apr 14, 2026 - 17:17 EEST

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 21:07 EET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2026 - 16:00 EET

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 21, 2026 - 08:54 EET
This incident affected: Web App.