eazybi.com servers upgrade
Incident Report for eazyBI
Resolved
eazybi.com is up and running
Posted 7 months ago. Mar 10, 2018 - 21:02 EET
Identified
eazybi.com will be unavailable for few minutes, scheduled maintenance in progress
Posted 7 months ago. Mar 10, 2018 - 20:51 EET