Scheduled maintenance
Incident Report for eazyBI
Resolved
Server upgrade done!
Posted 7 months ago. Jun 02, 2018 - 22:20 EEST
Investigating
Short scheduled maintenance break.
Posted 7 months ago. Jun 02, 2018 - 22:02 EEST
This incident affected: Web App and Docs.